1. Welcome to the Brawl website! Feel free to look around our forums. Join our growing community by typing /register in-game!

New Players Playing 1.9+ Could Be Scared Away

Discussion in 'Discussion' started by Gehenna_Beam, Sep 6, 2019.

  1. Gehenna_Beam

    Gehenna_Beam Wizard of Dysphoria

    Joined:
    May 19, 2015
    Messages:
    2,355
    Ratings:
    +1,012
    We advertise the server as supporting 1.8 - 1.14, but I haven't seen anything that says you'll get a poor experience if you play any version above 1.8.
    Players playing 1.9 or higher will log on and experience the compatibility issues and will say, "Wow, this server stinks! So buggy!" Though, I personally haven't logged in with 1.9 or higher in a long time. So, I'm not sure how bad the issues are.

    If we did advertise Brawl with the message "1.8 is recommended", would it help even just a little bit or continue to drive away players?
    I have a hunch that most play the latest version. These hardcore PVPers who want to stay on 1.8 or even go back to 1.7 are a minority. Most players log on for just a good time and don't have a passionate, hardcore, "mechanics focused" style of gameplay.

    With all that said, I could be wrong.
     
    • Like Like x 1
Loading...
Similar Threads Forum Date
Does a players playing style determine how good they are? Discussion Nov 3, 2014
afk players Ideas Aug 17, 2019
Kill Players Instantly When They Stand on a Barrier Block Ideas Aug 4, 2019
Intro Heya Fellow Players Intros & Outros Jul 9, 2019
Honoring The Players who made Raid good back in the day. Raid Jun 8, 2019